Archive for 八月 2009

人生如梦

手拿黑霉,月黑风高,随意嚓嚓,要知珍惜,冷静迎对,多学多想,思路清楚…………

创建VMware共享盘时出现“无法启动此程序,因为计算机中丢失LIBEAY32.DLL”

在VM虚拟机软件的安装文件夹下,有个vmware-vdiskmanager.exe文件,将它复制到共享磁盘文件夹下,然后使用如下命令创建共享磁盘:

vmware-vdiskmanager.exe -c -s 600Mb -a lsilogic -t 2 sharedisk.vmdk

这时就提示“无法启动此程序,因为计算机中丢失LIBEAY32.DLL”的错误,如下图:

vmerr001

这是因为将vmware-vdiskmanager.exe文件复制到其它文件夹后,就找不到原来安装目录下的LIBEAY32.DLL文件了,所以只需将VM安装目录下的LIBEAY32.DLL复制到C:WINDOWSSYSTEM32目录下即可。

VM虚拟机上“The parent virtual disk has been modified since the child was created”错误的解决方法

最近在打开一台虚拟机时出现了如下错误:
The parent virtual disk has been modified since the child was created

如下图:

vm11

查了下网上,主要是因为非法关机等导致虚拟盘出现问题。当某个盘出现问题时,在虚拟机的摘要中,盘的大小就为0,如下图:

vm12

解决步骤:

选择“编辑虚拟机设置”,选择0 bytes的盘符,这时就出现如下的错误,点击确定后,查看菜单中“磁盘文件”一项,如下图,这就是出问题的虚拟磁盘的配置文件,如下图:

vm13

然后使用如UltraEdit等文本编辑器打开该vmdk虚拟磁盘配置文件(….0_0000001.vmdk),注意找出两个选项,第一个为以parentCID开头的一行,第二个为以parentFileNameHint开头的一行,如下图:

vm14

然后再打开上图中parentFileNameHint一行后面指示的文件即父磁盘的磁盘配置文件(….-0.vmdk),如下图:

vm15

注意上图中的CID开头一行的值,这里为812e4778。而正常情况下的值应该为虚拟磁盘配置文件….0-0000001.vmdk中的parentCID的值,这里即为9f52a1b2。

所以出现此问题的故障,就是因为此虚拟盘配置文件的parentCID的值与父盘即parentFileNameHint开头一行所指的文件中的CID的值不同而造成的。至此,再次打开虚拟机,就不会出现The parent virtual disk has been modified since the child was created的错误了。

H3C交换机(S5500)策略路由配置笔记

写过华为S8508的策略路由,这次碰到一台H3C S5500,在配置上和华为交换机有些不同。大致配置如下:

拓扑图:

h3c55002

网络情况如下:

用户1网络:172.16.1.0/24
用户2网络: 192.168.1.0/24
至出口1网络:172.16.100.0/24
至出口2网络:192.168.100.0/24

实现功能:用户1通过互联网出口1,用户2通过互联网出口2。
功能实现:在三层交换台机上配置默认路由,将数据包丢向192.168.100.253,再利用策略路由,凡是用户2网络IP192.168.1.0/24的地址都丢向172.16.100.253。

配置步骤:

说明:这里接口的配置等操作就不在写了。

1、首先建立默认路由,将所有的数据包都丢往出口2的下一节点192.168.100.253

[H3C5500] ip route-static 0.0.0.0 0.0.0.0 192.168.100.253

2、配置流分类1,对象为172.16.1.0/24的数据

[H3C5500]acl number 3001

[H3C5500-acl-adv-3001] rule 0 permit ip source 172.16.1.0 0.0.0.255

[H3C5500] quit

[H3C5500] traffic classifier 1

[H3C5500-classifier-1] if-match acl 3001

[H3C5500-classifier-1] quit

3、配置刚才定义的流分类的行为,定义如果匹配就下一跳至出口1即172.16.100.253

[H3C5500] traffic behavior 1

[H3C5500-behavior-1] redirect next-hop 172.16.100.253

[H3C5500-behavior-1] quit

4、将刚才设置的应用至QOS策略中,定义policy 1

[H3C5500] qos policy 1

[H3C5500-qospolicy-1] classifier 1 behavior 1

[H3C5500-qospolicy-1] quit

5、在接口上应用定义的QOS策略policy 1

[H3C5500] interface GigabitEthernet 1/0/15

[H3C5500-GigabitEthernet1/0/15] qos apply policy 1 inbound

[H3C5500-GigabitEthernet1/0/15] quit

至此,配置已完成。

配置文件(略过一些接口配置信息):

version 5.20, Release 2102P02
#
sysname H3C5500
#
domain default enable system
#
telnet server enable
#
vlan 1
#
vlan 100 to 103
#
traffic classifier 1 operator and
if-match acl 3001
#
traffic behavior 1
redirect next-hop 172.16.100.253
#
qos policy 1
classifier 1 behavior 1
#
dhcp server ip-pool 1
network 192.168.1.0 mask 255.255.255.0
gateway-list 192.168.1.254
dns-list 221.228.255.1
#
dhcp server ip-pool 2
network 172.16.1.0 mask 255.255.255.0
gateway-list 172.16.1.254
dns-list 221.228.255.1
#
local-user huawei
password cipher .]@USE=B,53Q=^Q`M<1!!
service-type telnet terminal
level 3
#
acl number 3001
rule 0 permit ip source 172.16.1.0 0.0.0.255
#
interface NULL0
#
interface Vlan-interface1
ip address 192.168.0.254 255.255.255.0
#
interface Vlan-interface100
ip address 192.168.100.254 255.255.255.0
#
interface Vlan-interface101
ip address 192.168.1.254 255.255.255.0
#
interface Vlan-interface102
ip address 172.16.100.254 255.255.255.0
#
interface Vlan-interface103
ip address 172.16.1.254 255.255.255.0
#
interface GigabitEthernet1/0/1
port link-type access
port access vlan 100
speed 1000
duplex full
#
interface GigabitEthernet1/0/2
port link-type access
port access vlan 102
speed 1000
duplex full
#
interface GigabitEthernet1/0/15
port link-type trunk
port trunk permit vlan 1 101 103
speed 1000
duplex full
qos apply policy 1 inbound
#
interface GigabitEthernet1/0/16
port link-type trunk
port trunk permit vlan 1 101 103
speed 1000
duplex full
qos apply policy 1 inbound
#
ip route-static 0.0.0.0 0.0.0.0 192.168.100.253
#
dhcp enable
#
load xml-configuration
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 4
authentication-mode scheme
user privilege level 3
#
return

IBM Storage Manager 10.50更新及四个相关产品手册下载

几个IBM相关产品的操作手册:

1、IBMSystem Storage DS4700存储系统安装、用户与维护指南 (下载 下载2

2、IBM System Storage TS3100磁带库和TS3200磁带库安装、操作员与服务指南(下载 下载2

3、IBM System Storage TS3100磁带机安装快速参考(下载 下载2

4、IBM TotalStorage DS4000 Storage Manager 9用于AIX、HP-UX、Solaris和Linux on POWER的安装与支持指南(下载 下载2

 

IBM System Storage DS4000 Storage Manager v10.50:

一直使用的IBM Storage Manager 9,这次将它升级为10.50版了。(下载

ds4000mang10

黑霉8310使用教程2-常用软件

教程1:自己整理的黑莓8310使用教程

========================================

上篇整理的教程主要是桌面管理软件以及软件如何安装等,本篇将介绍我的8310上所使用的软件,至于软件的下载,提供一个软件压缩包。当然,也推荐在GOOGLE搜索软件名,这样可以下到最新版本的软件。

所有软件打包下载 (下载地址2

(1、软件排名不分先后^_^ 2、所有软件均来自互联网,各软件版权归原作者所有)

1、黑莓瑞士军刀BBSAK
一个装在PC机上的管理黑霉的工具,很实用,我也是这两天才装上用,对于第三方软件的备份很方便。
 bber2
 
2、BlackBerry BatteryWatch
了解电池的状态,如电量、温度、电压等。

3、ClockRevise
用来同步手机时间的小软件。进入软件后按D就开始同步了。

4、signal-location utilities
可以查看服务商相关信息,以及手机的相关版本等信息,据说可以手机移动定位,没用过这功能。
bber2

5、BlackBerry notepad
免费文本编辑软件,可以保存文本文件。方便写完保存后再当邮件的附件发送。

6、3G坛
一款浏览和使用各种互联网论坛以及资讯的免费手机软件。

7、opera Mini
opera推出的手机浏览器,如果你不喜欢BB自带的浏览器,可以试试这款。

8、BerryDict
BB在线英汉字典,通过CMNET流量实时查询,带发音功能。

9、凤凰移动台
喜欢看凤凰新闻的可以试试。

10、Google Sync
GOOGLE手机在线同步工具,我用它来同步BB的通讯簿与GMAIL里的联系人。
bber12

11、Fetion
中国移动的飞信,支持cmnet。我用了很长时间了,现在发消息的速度比黑霉本身发的都快。很好用。
bber13

12、WordPress
wordpress官方推出的黑霉版客户端,如果你有wordpress BLOG要维护,就可以使用它。可以让你轻松的在你的手机上完成一篇BLOG。
bber14-15

bber16-17

13、BBFileScout
免费文件管理器,可以压缩和解压缩文件,可以打开所有黑霉支持的媒体文件,等等,功能非常强大。
bber18-19

14、细搜天气查询
一个查询天气的小软件,走一部分网络流量。有很多版本,我喜欢文字版的。
bber20

15、JadBuilder
一款可以直接在黑莓手机上安装 cod 文件的免费工具。
bber21

16、sms scheduler
一款可以自定义短信发送时间的软件。我一直用它来查询GRPS流量,每天一次,只要编辑192每天早上8点发送至10086即可,如下图。
bber22

17、shangmail
沿邮邮件收发软件,有了它,在BB短信界面就可以直接编辑新邮件然后发送。我用它来收公司263邮箱的邮件。
bber23

18、MyAlarm
如果你觉得BB自带的闹钟功能太简单,可以试试这个小工具。
bber24

19、AutoKeyLock
自动锁屏幕工具。
bber25

20、BerryMail-QQ08
BB上的QQ客户端
bber26

21、路路通列车时刻表
出差的时候我一直用,呵。
bber27

22、黑霉来电助手
非常好用的软件,很早就使用上了,可以查询电话归属地及来电去电的地址,通话提醒等。功能很强大。
激活码:http://bbdev.org/active/
bber28-29

23、MobCal
移动万年历,可以查询吉日、节气等。
bber30

24、GoogleMaps
很COOL的软件,我去其它城市一般都用它。配合GPS,用起来效果很好。
bber31

25、QuickPull
有时你想重启BB,可能要拿出电池才行,这个小工具可以让你不拿出电池而重启BB。
bber32

26、四款小游戏
TornadoMania(疯狂龙卷风)、TowerBloxx(堆楼游戏)、Bobby carrot(兔子波比)、Puzzle Bobble Evolution(泡泡龙)
bber33-34

bber35-36

硬盘物理坏道修复工具-HDDRegenerator

2009年12月14日更新:距离上次修复整整4个月了,使用下来,一点问题没有。读写大文件也正常,没有发生磁盘错误等信息。

———————————————————

我工作用的一台VAIO本子(型号VGN-Y18C)最近在数据操作时经常出现“数据读取错误”之类的问题,找了个坏道检查工具-HDDRegenerator,网上也很多人用,自称该软件是直接对硬盘底层进行操作,使用后,我的37G的硬盘,花了26分钟,共修复了197个坏道,如下图。

redisk2

扫完重启后,再次扫描,就没有坏道了。接着重新分区格式化,用了一下午,还没有出错。但不知道最后的效果如何,等用了一个星期后就知道了。

软件名称:HDDRegenerator 下载注册汉化版